Cross your fingers about to try a new wireless card.

  • So currently I am running 2 AEX-QCA9880-NX, one for 2.4ghz bands and one for 5.0ghx bands in my apu2d4.

    I just received a AEX-QCA6391-NX1 that I want to see if I can get working under OpenWRT. The BT portion of the card wont work at all in the APU2 slots because the needed UART connections either run to the sim card or to the unpopulated sim. I may try an adapter later that will allow it just for grins.

    Hoping this isn't too power hungry. Looks like max power draw is under 700ma.

    Would be so nice to free up a slot. :)

  • So, did it work alright? :)

    If it works fine, and if you provided some details, we could add it to the list of supported Wi-Fi cards in the official documentation

    Life got busy, I plan on working with it tomorrow. I had a lot of trouble getting a custom openwrt compile done that would include the proper drivers and firmware for the QCA6391 I will give it a shot though. I also picked up a "WiFi 6 Mediatek MT7915 2T2R" card that the drivers should already be in the main branch.

    Also will be testing two usb3 to 2.5Gbps Ethernet adapters.

    Killer E3100 USB-C 3.1 to RJ-45 2.5Gbps Ethernet Adapter (100123) Realtek R8169 based

    ASUS 2.5G Ethernet USB Adapter (USB-C2500) Realtek R8152 based

    My broadband is 1.2Gbps speed so would like to use one of the above for uplink to my APU2D4. If I can get 1.2Gbps to it, I can live with 1Gbps out over Ethernet and having wifi. Or I may just bond two of the APU2's ports to my switch. Or maybe 1 usb adapter and one of these…-Converter/dp/B094YY6KX6/

    Will post some results tomorrow.

  • Yes the MT7915 works. Some caveats, the speed in AC vs AX modes, avg AC speed is 7-800's
    In AX I cant get it to break 400, yet.

  • Ok so here is where I am with this.

    Two 2.5Gbps usb 3 adapters

    RTL8152 has driver issues in both my openwrt 5.15 based kernel and 5.15 and higher manjaro kernels.
    RTL8169 can work in openwrt and manjaro 5.15 and later, though no extensive testing.
    Two Wifi 6 mini PCIe adapters
    MT7915 "works" with the current OpenWRT OpenWrt 22.03.0-rc1 and my custom roll of 5.15.x but on reboot it is not automatically starting.
    QCA6391 Cant even get it recognized as a device. Since its a pre-production product on a custom PCB, it may have been DOA too. Even so, this would require Ath11k drivers that are not in mainline OpenWRT yet and I had not gotten to getting them working in my build yet.

    I'll be honest, I haven't had this many network issues since win 95 dropped LOL.

    I think of all of it the MT7915 shows a LOT of promise, and should be fine after a few more driver revisions.

  • Final verdict on the 2.5Gbps usb adapters. If locked to 1Gbps, they function fine if you get the right drivers in place. Let them negotiate to 2.5Gbps and iperf tests only work up to just under 700Mbps. It uses up 100% of the core its running on and limits the bandwidth. I may still try a 2.5Gbps Intel I225 based mini pcie but I am afraid we have just reached some limitations of the platform currently.

    Going to roll back to their current RC and drop this back into production to test the MT7915 for reliability (will be weird to only need 2 antennas vs the 6 I had before. Will update this thread later with results on the MT7915.

    Not sure why I could never get QCA6391 to work. Unless there is broken or funky about its pinout.

  • Appears the MT7915 has heat issues. With no added cooling some folks are reporting temps in excess of 100c I have heatsinks coming and will report back. Card still working well, just gets hot.

    Mine is currently clocking in at 74c, CPU is at 53c and my cooling for the CPU is stock with the exception of using a copper plate instead of the aluminum ones that come with our cases normally.

    root@ghost:~# sensors


    Adapter: PCI adapter

    temp1: +74.0°C (high = +120.0°C, crit = +110.0°C)


    Adapter: PCI adapter

    temp1: +53.2°C (high = +70.0°C)

    (crit = +105.0°C, hyst = +104.0°C)


    Adapter: ACPI interface

    temp1: +53.2°C (crit = +115.0°C)


    Adapter: PCI adapter

    temp1: +74.0°C (high = +120.0°C, crit = +110.0°C)


    Adapter: PCI adapter

    power1: 2.77 W (interval = 0.01 s, crit = 6.00 W)

  • I actually have the MT7915 card in my apu2 too, the non-DBDC version from AsiaRF:…g-n-2-4g-5ghz-aw7915-np1/

    I'm getting over 1Gbps in iperf3 (server running on the apu2 itself) on openwrt 21.02.2, and 700-900 mbps to WAN (highly depends on workload, apu2 benefits from multiple connections). Card is running in AX mode, contiguous 160MHz mode on channel 120. OpenWRT 22 has lower LAN <-> WAN performance, flow offload is a bit slower now probably due to the switch to nftables, so for now I'm sticking to 21.02.

    My card also gets pretty hot - i've once seen it go to 130 degrees C. In OpenWRT 22, the newer driver finally implements thermal throttling so the card won't exceed 100 degrees, but still. I now have this oversized 11mm thick heatsink on my card now and it just, barely fits into the original apu2 enclosure, and the temps are much more tolerable now. Limiting output power also helps bring temps down a bit. I've noticed no significant drop in performance going from 26 dBm to 23 dBm.


    The CPU scaling is not working well enough in openwrt

    That is interesting, how did you fix it? just set the governor to performance? Wonder how that impacts CPB

  • I've not tested the MT7915 with iperf because I am always happy with anything over 30Mbps on wifi. I cant run at 160Mhz only 2 of my 5 5Ghz clients support it currently. It runs very hot with my case closed (59-74c) so I have ordered a heatsink for it.…dt_b_product_details&th=1 just waiting to replace the cheap TIM inside the RF lids tonight before putting it all together. [Blocked Image:]

    Not attached yet just there for the pic.

    [Blocked Image:]

    Since obviously they knew it needed to be cooled.

    As for the CPU scaling yeah I run the following script after boot;

    That seems to let the adapter work at 2.5Gbps for data transfer but iperf and iperf3 are still too cpu hungry, also the cdc_ncm driver that its picking by default doesnt provide any data with ethtool, have not figured out how to properly blacklist that driver so it picks the R8152 one instead. The clock speeds shown in htop still drift in the 900Mhz range.

    1. root@ghost:~# ethtool eth3
    2. Settings for eth3:
    3. Current message level: 0x00000007 (7)
    4. drv probe link
    5. Link detected: yes
  • Quote

    I cant run at 160Mhz only 2 of my 5 5Ghz clients support it currently

    It should not be a problem, devices without 160MHz support will just fall back to a narrower channel width that they support. I have some non-160MHz clients connected to mine for example.

  • It should not be a problem, devices without 160MHz support will just fall back to a narrower channel width that they support. I have some non-160MHz clients connected to mine for example.

    So iIt shouldnt but with 160Mhz on it turns out the interface doesnt come up. It's likely the card is not DFC certified for use in the US. So if I select Us region it wont tenable if I choose 160Mhz? Maybe?


    My heatsink mod/update netted me about a 12% drop in temps with the cover on. Not bad, but not great. The layers are the problem I am sure. I may see if I can get a larger copper billet style heatsink that could replace the RF cover and then machine the bottom face so that its just big enough to sit on the IC's and then attach it with thermal epoxy directly. For me that would be a lot of hand filing. Some more details here;

  • So I was able to get both USB Ethernet adapters working. I am currently running without using the onboard Ethernet ports.


    1. [Tue Jul 5 16:04:19 2022] cdc_ncm 3-1:2.0 eth3: 2500 mbit/s downlink 2500 mbit/s uplink
    2. [Tue Jul 5 17:09:45 2022] cdc_ncm 3-2.3:2.0 eth4: 2500 mbit/s downlink 2500 mbit/s uplink

    Unfortunately I am having issues with my broadband so still not fully able to test my 1.2Gbps service.


    Wont have broadband fixed till next week (ugh) but I can say that I am hitting a CPU core max out. If I run a speed test they are maxing out at 240Mbps. Core 0 is at 100% cpu.

    I tried stopping and restarting the irqbalance service, futzing with the settings, etc but no matter what I do I cant seem to get irq31 to spread across cores.

    So at the end of the day unless I can get a working 2.5Gbps mini PCIe card it looks like the hope of breaking the 1Gbps barrier on the apu is a lost cause for the average user. Frankly I am starting to look to build a low power Alder lake based router and may just setup my APU as an AP only.

  • Success!

    So with this adapter;

    I can get a 2.5Gbps uplink to my MB8611 cable modem. Which is connecting at just over 1.2Gbps to my broadband connection. The APU can handle the load with a PCIe Mini card because unlike with the usb based solution the IRQ load is spread across all 4 cores of the CPU. This is all with the standard timings. My cores are running around 600mhz at idle.

    Next step is bonding two of the I210's to my Mikrotek switch as a single interface.

  • And with this adapter;

    I got the Intel I225 M.2 B + M card working.…SY-PEX24075/dp/B09SRW3RCV

    This adapter worked with the intel nic also

    1. 59: 0 3 0 0 PCI-MSI 2621440-edge eth3
    2. 60: 2628 7370 45862 139694 PCI-MSI 2621441-edge eth3-TxRx-0
    3. 61: 79258 3333 13089 70307 PCI-MSI 2621442-edge eth3-TxRx-1
    4. 62: 72587 12703 5020 4520 PCI-MSI 2621443-edge eth3-TxRx-2
    5. 63: 246592 83325 6261 4015 PCI-MSI 2621444-edge eth3-TxRx-3
    6. [ ID] Interval Transfer Bitrate Retr
    7. [ 5] 0.00-10.00 sec 1.58 GBytes 1.36 Gbits/sec 31 sender
    8. [ 5] 0.00-10.00 sec 1.58 GBytes 1.36 Gbits/sec receiver

    You can see the both of the mini PCIe adapters balance their load across the cores which the xhci_hcd driver in openwrt does not try to do for the USB based adapters.

    Performance is crisp and stable. So 2.5Gbps/sec connection, with Wifi 6 on APU2, yes, it can work. :)