APU4 can't read SIM card

  • I have 2 APU4D4 's and have installed Quectel EC25 modems in mPCIe slot 2. I'm running Ubuntu server 20.04 and I've also tried DD-WRT. In both OS's the modem can't read the SIM card. I've tried both slots with no luck. I took the modem out and put it in a mPCIe to USB adapter that had a built in SIM card slot and everything worked perfectly, I was able to read the SIM and attach to the cellular network.

    In looking at the schematics it appears that there is a SIM switch between the SIM sockets and the mPCIe slots. I wonder if that is the source of the problem?

    Any thoughts on trouble shooting my 2 APU4D4 boards that act the same?


  • Hi James,

    Please refer which slots may be used for USB modems with SIM card slots: https://github.com/pcengines/a…ties.md#apu4a-apu4b-apu4c

    If you put the Quectel EC25 to mPCIe1 slot it won't work with SMI slots on the board. Regarding the SIM swap pin, it simply selects the SIM switch behavior. By default SISMWAP pin is in low state which means the SIM cards are "crossed":
    - mPCIe2 slot is connected to SIM2
    - mSATA slot is connected to SIM1

    So basically if you have tried both SIM slots, one of two should work for mPCIe2 slot.
    We have some Quectel EC25 I believe and may test something out.

    Best regards,

  • I tried randomly different firmware version without success.
    Any idea what I can do ?