Alix 2D3 (and presumably 2D13) - use of IDE/PATA alongside CF

  • Hi,


    I have an Alix 2D3 in production that I've run for years reliably. Current storage is on a CF card in the CF bay.


    I've picked up a 44-pin PATA/IDE cable so that I can use the on-board interface for secondary storage. Twice I've connected a CF-to-PATA interface (with a CF card installed of course) - once in Master mode and once in Slave mode - but the system hasn't seen it either time.


    I'd like to get some clarification:


    - can the 44-pin PATA (IDE) interface be used simultaneously with the CF slot?

    - if so, is the interface expecting a drive in Slave mode (with the CF card the master)? I know one of the Alix 1dx models has a header you can jumper to make the CF slot slave, but the 2dx manual makes no mention of a similar feature.

    - has anyone actually gotten this working?


    I am pretty sure from my reading that there is only a single functioning PATA/IDE interface on the board, so using two devices would require one being primary and the other, slave.


    Perhaps I'm missing the mark and using the interface automatically disables the on-board CF slot on the 2dx Alixes.


    I have updated the firmware on the Alix to 0.99m, and enabled slave device scanning. I also tried disabling UDMA, in case it was causing issues, and adding the IDE device scan delay (even though I'm not using spinning disks). Not that it should matter, but I've also sped up the serial console text to 115.2kbps just to be consistent with my APUs (and pleasantly faster too!).


    Can anyone give me some direction? Ideally I'd like to have dual CFs (or potentially down the road, one CF and one mSATA-via-PATA adapter) so that I can have the system run as Linux mdadm RAID1 so that I can tolerate a device failure. (I've done this with one of my APU1s and am about to do it to the other, but on that device, the mSATA slot and the SATA port are logically separate and the only hiccup is in selecting the boot device.)


    Thanks,


    Jim

  • I've been using this setup on a very old Alix board for many years (don't know the specific model now).


    I think there was nothing special with it. Just connect it (try slave if master doesn't work), boot, and run blkid, there should be a /dev/sdb. lspci says my driver is pata_cs5536.