APU2C Console freezes after few seconds

  • Hi,
    I've got a used APU2C board from family and would like to fresh install a new OS.

    When I connect via the serial console, I do see the board booting and can interact (change boot device, perform memory test,...) for a few seconds (around 10-50s) before the console freezes.

    It then doesn't show any new output and doesn't respond to any input.

    Reconnecting doesn't work, I have to reboot the board.

    I've tested with Linux, MacOS and Windows with the clients Minicom, Screen, Putty.

    I've tested 2 different USB console adapters and different RJ45 to RS232 adapters. All show the same behaviour (except that it doesn't work at all when using the wrong pin-out).

    Connection settings are 115200,8N1 as suggested in various docs.

    Could anyone point me into something I've missed or things I haven't tried yet?
    Any help is greatly appreciated.

  • Hi and thanks for the reply.

    Today I had some time to fiddle around a bit more, but unfortunately still no success.

    I was trying to access the BIOS setup menu, but still, the console freezes after a few seconds and I'm not fast enough to find and change the settings.

    I already tried to remove and cards etc which are connected to the board, but still same behavior.

    I'm more and more thinking this board may have reached it's end of life. Which is really frustrating, because it's still working, but only for about 3-4sec now and then locks up.